Re: ncurses-4.0 un-announcement

From: T.E.Dickey <>
Date: Fri, 27 Dec 1996 07:50:03 -0500 (EST)

> The ncurses-1.9.9g release earlier this month caught most people by
> suprise. The fact that is was released at all makes no sense (but see
> below).
both were announced on the mailing list (and I received my copy via the mailing
list, so I'm reasonably certain that you also received the announcement in that
manner). The understanding I had with Zeyd was that he'd issue the
announcement for 4.0 -- but he's not responded, so I'll probably issue it
> Another quick release? Let's hope that it's stable. But I get the
> impression that this is for Linux only, as it has not appeared for
> other platforms at other places, eg,,
>, etc.
I don't know about the upload policy at prep.
And alpha has never been a release site for ncurses afaik.
You meant to say "ftp site" rather than "platform", which has a different
connotation hereabouts.

As for "platforms", bear in mind that I've done most of the ports.
I've built 4.0 on Linux, Solaris (cc, gcc), SunOS (gcc), IRIX (cc, gcc),
CLIX (cc, gcc), HP-UX (gcc) (due to network problems I don't have the
other machines up: AIX, SCO, Unixware).

(I've not gotten any serious feedback from users on FreeBSD or NetBSD
for some time).
> Why this release? Why now? How different is the 4.0 API from 1.9.9e
> and 1.9.9g? What are the implications? Do I need to recompile things
read the NEWS file: it fixes the incompatibilies introduced by the newer on Linux. That was the main impetus to making a release, and has
been a known problem since late September, though the release of
made it a serious problem.

> to get them relinked against libncurses-4.0 before I can get rid of my
> old 1.9.9{e,g} shared libs? Or will work seamlessly
> with all my current ncurses-linked applications?
probably will. There's no change other than version number in the binary
interface for 4.0 vs 1.9.9g (1.9.9e is a different matter altogether).
> >From the 10k TO-DO list, it seems that there is still much to do.
> How far away is ncurses-5.0? Was 4.0 really ready for release?
5.0 will probably introduce binary incompatibilities. I have two in
mind. 4.0 was ok for release. The TO-DO list items aren't new (I added
a couple as reminders, but those are issues through this entire calendar
(1996) year, since January.

Thomas E. Dickey
Received on Fri Dec 27 1996 - 07:58:43 EST

This archive was generated by hypermail 2.2.0 : Sun Dec 18 2011 - 14:23:30 EST